【通达信】十金叉选股指标公式600718

N1:=3;N2:=5;N3:=9;N4:=13;N5:=21;N6:=34;
DRAWBAND(5,RGB(50,5,50),0,RGB(55,5,5));
DIFF:=EMA(CLOSE,N3)-EMA(CLOSE,N4);
DEA:=EMA(DIFF,N2);
A1:=DIFF>DEA;
RSV1:=(CLOSE-LLV(LOW,N3))/(HHV(HIGH,N3)-LLV(LOW,N3))*100;
K:=SMA(RSV1,N1,1);
D:=SMA(K,N1,1);
LC:=REF(CLOSE,1);
RSI1:=(SMA(MAX(CLOSE-LC,0),N2,1))/(SMA(ABS(CLOSE-LC),N2,1))*100;
RSI2:=(SMA(MAX(CLOSE-LC,0),N4,1))/(SMA(ABS(CLOSE-LC),N4,1))*100;
A3:=RSI1>RSI2;
RSV:=-(HHV(HIGH,N4)-CLOSE)/(HHV(HIGH,N4)-LLV(LOW,N4))*100;
LWR1:=SMA(RSV,N1,1);
LWR2:=SMA(LWR1,N1,1);
A4:=LWR1>LWR2;
BBI:=(MA(CLOSE,N1)+MA(CLOSE,N2)+MA(CLOSE,N3)+MA(CLOSE,N4))/4;
A5:=CLOSE>BBI;
MTM:=CLOSE-REF(CLOSE,1);
MMS:=100*EMA(EMA(MTM,N2),N1)/EMA(EMA(ABS(MTM),N2),N1);
MMM:=100*EMA(EMA(MTM,N4),N3)/EMA(EMA(ABS(MTM),N4),N3);
A6:=MMS>MMM;
BIAS:=(C-MA(C,N2))/MA(C,N2);
DIF:=(BIAS-REF(BIAS,16));
DBCD:=SMA(DIF,76,1);
MM:=MA(DBCD,5);
A7:=DBCD>MM;
持股:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK0,COLORRED;
下跌:=MA(持股,12),COLOR6B8E23,LINETHICK0;
MA1:=MA(持股,5);
{www.gainiangu.com 概念股网_通达信股票指标公式}
向下:=CROSS(MA1,持股) AND MA1>80;
A8:=持股>下跌;
MT:=C-REF(C,1);
ZLGJ:=100*EMA(EMA(MT,N3),N3)/EMA(EMA(ABS(MT),N3),N3);
MAZL:=MA(ZLGJ,5);
PJJ:=DMA((HIGH+LOW+CLOSE*2)/4,0.9);
JJ:=REF(EMA(PJJ,3),1);
QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
XVL:=IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSEOPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSEHSL:=(XVL/20)/1.15;
攻击流量:=((HSL*0.55+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.22));
LLJX:=EMA(攻击流量,3);
资金流量:=LLJX,LINETHICK0,COLOR0000FF;
SS:(DIFF>DEA AND K>D AND RSI1>RSI2 AND LWR1>LWR2 AND CLOSE>BBI AND MMS>MMM AND
DBCD>MM AND 持股>下跌 AND ZLGJ>MAZL AND 资金流量>0)*2.5,COLORRED;